Making a Poster with Scribus

Introduction

This document offers hints on how to create a scientific poster with Scribus, an open-source page-layout application. Scribus is free and is available for MacOS, Windows, and Linux. Note that Scribus is already well-documented (and there are several tutorials available on the web). For many questions, you may find general documentation more useful than this guide. In particular, be sure to read this page if you aren't familiar with the concept of using a page-layout application. You might also want to look at this guide with general hints for designing and presenting a scientific poster in biology.

Hints

Don't just start up Scribus and start clicking around! You should begin your poster by assembling everything you're planning to use to create the poster. Creating a poster using a Desktop Publishing application requires a different workflow than Powerpoint.

First, create a directory that will contain all of the media elements that you want to use. Save images and the large blocks of text into separate files. You can use almost any format for images. Your images must be reasonably high resolution (200dpi) if you expect them to look good when printed. Scribus can open plain text files, Open Office files (.odt), and html files. Note that text, once imported, is included within the poster document while images remain as separate media elements. In other words, if you change or move the image file, it will be changed or disappear in the poster.

Use the highest-quality graphics you can find. Use vector-based imagery for graphs and figures. Create PDF files from the applications where you created the graphs and put them in your folder. Don't use bitmapped images unless absolutely required and use the highest-resolution version available: aim for at least 200dpi. (Images at Flickr.com have an "All Sizes" button that will let you find the highest resolution version available). If you must use screen-captures, try to make the graphic completely fill the screen then CMD+Shift+4.

Make sure you have copyright-clearance to use all graphics. (In other words, you should (1) make them yourself or (2) have written permission from the copyright holder or (3) use Creative Commons licensed or Public Domain imagery. You can find lots of creative commons licensed imagery at Flickr.com -- use Advanced Search to search only creative commons images and then follow the directions, including adding acknowledgements regarding the creator of the image.)

Before you start Scribus, make a sketch on paper that shows roughly what the poster is going to look like and where you're planning elements will go.

When you first start up Scribus, don't immediately create your document. Click cancel. First, click the green window button to resize the window to fill the screen. Second, open the "Properties" window (under Window menu) and move it to the right-hand side of the screen -- you'll need it a lot. Finally, check the color space under the Edit menu and pick the color space you want. I suggest "Pantone Coated". Now you're ready to create your document.

When you create your document, you will probably want to set the Units to Inches first. Then set the Document Size to "Custom" (at the bottom of the list) and set the height and width of the poster. Remember that one of the two dimensions should match one of the rolls of paper we have for our printer (either 36" or 42").

When you start Scribus, it brings up a new document dialog box. Set the "Size" to "Custom" and then fill in the Width and Height fields with values in inches (e.g. "36in"). When you enter these values, Scribus will convert them to the units being used in the document. By default, Scribus uses "points" (1/72 of an inch) as the unit of measure, although you can change that to something else if you prefer. You can set the margins and margin guides to 0, or leave some white space around the edge of your poster. Often, after changing a measurement value in a preference or properties form, you have to press Enter to get it to take effect. When changing properties of text (including the application of Paragraph Styles) in a text box (right click, Edit text), the text must be highlighted, and you must press enter e.g. after changing the font size.

Save your work so far. Save the document into the folder with your other media elements. Save regularly. Save more than regularly. And if you need to open a Scribus document, don't just double-click on it. Start Scribus and open the document from within Scribus. You're welcome.

One other thing. Scribus does an autosave every 10 minutes. The file it creates is labeled .autosave. Rename the file to remove the .autosave extension and you can open the file in Scribus.

You can set global variables for the document in the "Document Setup" under the "File" menu. Under "Tools" there are a variety of basic settings you make for the default font, font size, etc. Most of this stuff you'll set again when you make Paragraph Styles anyway but you can save a little time by creating thoughtful defaults. You may want to change the default unit e.g. from points to inches. Now you can set the desired width and height of the poster. If you want grid lines (recommended), open Preferences in the Scribus menu, and click on Guides in the left column. Check what you want. When I did this AFTER creating my first poster, I could never get the grid lines to display.

Sizing/Zoom for View: A poster fits on the screen at about 25% zoom. To get to 25% quickly, click the 100% button (near the lower left, a magnifying glass with “1”, next to those with “-“ and “+”), then the ½ button (“-“) twice.

Since you already sketched out your poster on paper, you should have a good sense for where and how big you want elements to appear, create empty text, image, and table frames and position them roughly where you will want them to appear. Use the “Insert Text Frame” and “Insert Image Frame” buttons (in the top line of icons in the Scribus window – touch icons with the mouse to see the tool tips) to insert those items. With text, right click, Edit Text. With images, right click, Get Image.

You might want to turn on a grid (under the "View" menu) and set "Snap to Grid" (under the "Page" menu). Or you may want to create "Guides" (use "Manage Guides" under the "Page" menu) which will help you line up elements at particular points.

Figure out what different kinds of text elements your poster will contain: titles, contact info, blocks of text, headings, figures, tables, etc. For each text element, consider creating a "Paragraph Style" (under the "Edit" menu). Styles will define the font size, spacing, etc of the text for that kind of element. Note that you don't want to try to apply formatting to frames as a substitute for creating styles.

When you have created frames for all your elements, begin importing the text and graphics into the frames you've created for them. You can do this by right-clicking on the frame and using "Get Text" or "Get Image". To format the text, use the "Story Editor" to apply a style to the text.

Once you have all the content into the frames, you can begin working on tweaking each frame to look the way you want and to work with the rest of the poster. You can make small changes to your Paragraph Styles, which will affect all of the text using that style across multiple frames. You can right click and select "Properties" of frames to make adjustments on how the frame and it's contents are presented. You can configure a frame to make text in other frames wrap around it. You can make images scale to fit in frames: After getting the image into the image frame, right click, Adjust Image to Frame. Then you can resize the frame and the image resizes with it. You can also configure Scribus to work with external image editing programs. The full details of how to do Desktop Publishing and the capabilities of Scribus are beyond the scope of this guide.

You should be aware that Scribus offers particularly powerful tools for working with typography. The spacing in very large type will often "look" wrong. In the Story Editor, select two (or more) characters and increase or decrease the value of the Manual Tracking (it looks like A|V with an arrow under it). Sometimes this is called "kerning". Now you can fix those places where the gap is too large or too small. Text line spacing (in text boxes) seems to default to a fixed value. I could not find any place to change this default. Right click, then Properties, then Text, then change Fixed Line Spacing to Automatic Line Spacing. You would think this could be set in the Edit Text box, where much more advanced things can be set, but I could not find any line spacing controls there.

Shadow behind a text box. Scribus doesn’t provide this. You can fake one (but it has sharp edges) as follows: Click on the text box so it has a red box around it. Item (top menus), Duplicate. Right click on item, Properties, convert to polygon. In Properties, Colors, select Fill button (it turns gray when selected), Fill with black. Lower the “Shade” to make gray. Offset. Then, if you need to move the shadowed text box, first group them together so they move as a unit:

When your poster is ready, you can print it directly or generate a PDF that you can print with another application. Be sure to select "Set Media Size" under the "Advanced" options of the printing dialog -- otherwise it may think you want to print on Letter size paper. When you're ready to print, go on to the Poster Printing document to see how to configure your computer to print to the printer.

Non-responsive dialog. Often, when you click in a dialog, nothing happens (in OS X). This may be a focus issue. Click on the frame of the dialog, or outside the dialog, then try again. It usually works then.

Grouping: Unlock each item first! (There are two lock options on the Item menu.) Select multiple items with Shift Click (works in Mac OS X), then Item, Group. Then lock the group.

Polygons (triangles, squares) can have their corners dragged into any position. At first, they appear to be constrained into a square bounding box. The trick is to double-click the polygon. A “Nodes” dialog will appear. Don’t worry about what is in the dialog (leave it alone) – when it is visible, the corners of the polygon turn into blue circles, and these can be dragged at will. Then click “End editing” in the “Nodes” dialog.

“Lines”: For polygons, in their properties (right click to get properties), the Line section controls the border line for the polygon. To have no border, go to Colors (not Lines), depress the Lines button (not the Fill button), and set the color to “None”. Similarly, the Lines section of Properties controls the border of text and image frames.

Text color is controlled in the Text section of the text frame’s Properties (right click to get Properties). Background color of the text frame is under Colors, with the Fill button depressed. As stated above, the Line section of Properties, and the Line button under Colors, button control the frame border line (if any) around the text frame.